NetSight
critical9.8

CVE-2024-12029

InvokeAI Deserialization of Untrusted Data vulnerability

Impact

A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3rc2.

Affected packages

EcosystemPackageAffectedFixed in
pipInvokeAI>= 5.3.1, < 5.4.3rc25.4.3rc2

Affected products

ProductAffected versions
Invoke-Ai/Invokeai Versions 5.3.1
through 5.4.2

Versions were read from the advisory text. No structured product data has been published for this record yet.

Weakness classification

References