high7.1
CVE-2024-12911
LlamaIndex vulnerable to Creation of Temporary File in Directory with Insecure Permissions
Impact
A vulnerability in the `default_jsonalyzer` function of the `JSONalyzeQueryEngine` in the run-llama/llama_index repository allows for SQL injection via prompt injection. This can lead to arbitrary file creation and Denial-of-Service (DoS) attacks. The vulnerability affects the latest version and is fixed in version 0.12.3.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | llama-index | < 0.12.3 | 0.12.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Llamaindex | Llamaindex | before 0.5.1 |