NetSight
high7.7

CVE-2024-1329

HashiCorp Nomad vulnerable to symlink attacks

Impact

HashiCorp Nomad and Nomad Enterprise 1.5.13 up to 1.6.6, and 1.7.3 template renderer is vulnerable to arbitrary file write on the host as the Nomad client user through symlink attacks. Fixed in Nomad 1.7.4, 1.6.7, 1.5.14.

Affected packages

EcosystemPackageAffectedFixed in
gogithub.com/hashicorp/nomad= 1.5.131.5.14

Affected products

VendorProductAffected versions
HashicorpNomad
from 1.5.13 before 1.5.14
from 1.6.6 before 1.6.7
from 1.7.3. before 1.7.4

Weakness classification

References