NetSight
medium6.5

CVE-2024-2035

Improper authorization in zenml

Impact

An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint. This vulnerability allows any authenticated user to modify the information of other users, including changing the `active` status of user accounts to false, effectively deactivating them. This issue affects version 0.55.3 and was fixed in version 0.56.2. The impact of this vulnerability is significant as it allows for the deactivation of admin accounts, potentially disrupting the functionality and security of the application.

Affected packages

EcosystemPackageAffectedFixed in
pipzenml< 0.56.20.56.2

Affected products

VendorProductAffected versions
ZenmlZenml
before 0.56.2

Weakness classification

References