high7.6
CVE-2024-21637
Authentik is an open-source Identity Provider.
Impact
Authentik is an open-source Identity Provider. Authentik is a vulnerable to a reflected Cross-Site Scripting vulnerability via JavaScript-URIs in OpenID Connect flows with `response_mode=form_post`. This relatively user could use the described attacks to perform a privilege escalation. This vulnerability has been patched in versions 2023.10.6 and 2023.8.6.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Goauthentik | Authentik | from 2023.8.0 before 2023.8.6 from 2023.10.0 before 2023.10.6 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/goauthentik/authentik/releases/tag/version%2F2023.10.6
- https://github.com/goauthentik/authentik/releases/tag/version%2F2023.8.6
- https://github.com/goauthentik/authentik/security/advisories/GHSA-rjpr-7w8c-gv3j
- https://github.com/goauthentik/authentik/releases/tag/version%2F2023.10.6
- https://github.com/goauthentik/authentik/releases/tag/version%2F2023.8.6
- https://github.com/goauthentik/authentik/security/advisories/GHSA-rjpr-7w8c-gv3j