NetSight
medium4.8

CVE-2024-2171

Cross site scripting in zenml

Impact

A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logo_url' field. By injecting malicious payloads into this field, an attacker could send harmful messages to other users, potentially compromising their accounts. The vulnerability affects version 0.55.3 and was fixed in version 0.56.2. The impact of exploiting this vulnerability could lead to user account compromise.

Affected packages

EcosystemPackageAffectedFixed in
pipzenml< 0.56.20.56.2

Affected products

VendorProductAffected versions
ZenmlZenml
before 0.56.2

Weakness classification

References