NetSight
medium5.3

CVE-2024-21733

Apache Tomcat vulnerable to Generation of Error Message Containing Sensitive Information

Impact

Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat:tomcat-coyote>= 9.0.0-M11, < 9.0.449.0.44
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 8.5.7, < 8.5.648.5.64
mavenorg.apache.tomcat.experimental:tomcat-embed-programmatic>= 9.0.43, < 9.0.449.0.44

Affected products

VendorProductAffected versions
ApacheTomcat
from 8.5.7 before 8.5.64
from 9.0.1 before 9.0.44
Version 9.0.0

Weakness classification

References