low3.3
CVE-2024-2213
Improper authentication in zenml
Impact
An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | zenml | < 0.56.3 | 0.56.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Zenml | Zenml | before 0.56.3 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/zenml-io/zenml/commit/58cb3d987372c91eb605853c35325701733337c2
- https://huntr.com/bounties/8f5534ac-fd08-4b8b-8c2e-35949aa36e48
- https://github.com/advisories/GHSA-j527-v579-m98h
- https://nvd.nist.gov/vuln/detail/CVE-2024-2213
- https://github.com/pypa/advisory-database/tree/main/vulns/zenml/PYSEC-2024-193.yaml