NetSight
low2.9

CVE-2024-22371

Apache Camel data exposure vulnerability

Impact

Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel. This issue affects Apache Camel: from 3.0.0 through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0. Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.camel:camel-core= 3.22.03.22.1

Affected products

VendorProductAffected versions
ApacheCamel
from 3.0.0 before 3.21.4
from 4.0.0 before 4.0.4
from 4.1.0 before 4.4.0
Version 3.22.0

Weakness classification

References