NetSight
high7.6

CVE-2024-22421

JupyterLab vulnerable to potential authentication and CSRF tokens leak

Impact

### Impact Users of JupyterLab who click on a malicious link may get their `Authorization` and `XSRFToken` tokens exposed to a third party when running an older `jupyter-server` version. ### Patches JupyterLab 4.1.0b2, 4.0.11, and 3.6.7 were patched. ### Workarounds No workaround has been identified, however users should ensure to upgrade `jupyter-server` to version 2.7.2 or newer which includes a redirect vulnerability fix. ### References Vulnerability reported by user @davwwwx via the [bug bounty program](https://app.intigriti.com/programs/jupyter/jupyter/detail) [sponsored by the European Commission](https://commission.europa.eu/news/european-commissions-open-source-programme-office-starts-bug-bounties-2022-01-19_en) and hosted on the [Intigriti platform](https://www.intigriti.com/).

Affected packages

EcosystemPackageAffectedFixed in
pipjupyterlab>= 4.0.0, <= 4.0.104.0.11
pipnotebook>= 7.0.0, <= 7.0.67.0.7

Affected products

VendorProductAffected versions
JupyterJupyterlab
before 3.6.7
from 4.0.0 before 4.0.11
JupyterNotebook
from 7.0.0 before 7.0.7
FedoraprojectFedora
Version 39

Weakness classification

References