NetSight
critical9.8

CVE-2024-23114

Deserialization of Untrusted Data in Apache Camel CassandraQL

Impact

Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is vulnerable to unsafe deserialization. Under specific conditions it is possible to deserialize malicious payload.This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.camel:camel-cassandraql>= 3.0.0, < 3.21.43.21.4

Affected products

VendorProductAffected versions
ApacheCamel
from 3.0.0 before 3.21.4
from 4.0.0 before 4.0.4
from 4.1.0 before 4.4.0
Version 3.22.0

Weakness classification

References