medium5.4
CVE-2024-23349
Apache Answer Cross-site Scripting vulnerability
Impact
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Answer. This issue affects Apache Answer through 1.2.1. XSS attack when user enters summary. A logged-in user, when modifying their own submitted question, can input malicious code in the summary to create such an attack. Users are recommended to upgrade to version 1.2.5, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/apache/incubator-answer | < 1.2.5 | 1.2.5 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Answer | through 1.2.1 |