high8.2
CVE-2024-23841
@apollo/experimental-nextjs-app-support Cross-site Scripting vulnerability
Impact
### Impact The @apollo/experimental-apollo-client-nextjs NPM package is vulnerable to a cross-site scripting vulnerability. This vulnerability arises from improper handling of untrusted input when @apollo/experimental-apollo-client-nextjs performs server-side rendering of HTML pages. To fix this vulnerability, we implemented appropriate escaping to prevent javascript injection into rendered pages. ### Patches To fix this issue, please update to version 0.7.0 or later. ### Workarounds There are no known workarounds for this issue. Please update to version 0.7.0
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | @apollo/experimental-nextjs-app-support | <= 0.6.0 | 0.7.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apollographql | Apollo Client | before 0.7.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/apollographql/apollo-client-nextjs/commit/b92bc42abd5f8e17d4db361c36bd08e4f541a46b
- https://github.com/apollographql/apollo-client-nextjs/security/advisories/GHSA-rv8p-rr2h-fgpg
- https://github.com/advisories/GHSA-rv8p-rr2h-fgpg
- https://nvd.nist.gov/vuln/detail/CVE-2024-23841