NetSight
high7.5

CVE-2024-24549

Apache Tomcat Denial of Service due to improper input validation vulnerability for HTTP/2 requests

Impact

Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 8.5.0, <= 8.5.988.5.99
mavenorg.apache.tomcat:tomcat-coyote>= 11.0.0-M1, <= 11.0.0-M1611.0.0-M17

Affected products

VendorProductAffected versions
ApacheTomcat
from 8.5.0 before 8.5.99
from 9.0.0 before 9.0.86
from 10.1.0 before 10.1.19
Version 11.0.0
DebianDebian Linux
Version 10.0
FedoraprojectFedora
Versions 39, 40

Weakness classification

References