NetSight
medium4.9

CVE-2024-24773

Apache Superset: Improper validation of SQL statements allows for unauthorized access to data

Impact

Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-superset<= 3.0.33.0.4

Affected products

VendorProductAffected versions
ApacheSuperset
before 3.0.4
from 3.1.0 before 3.1.1

Weakness classification

References