medium6.5
CVE-2024-24778
Apache StreamPipes has improper privilege management in a REST interface
Impact
Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was known. This issue affects Apache StreamPipes: through 0.95.1. Users are recommended to upgrade to version 0.97.0 which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.streampipes:streampipes-parent | < 0.97.0 | 0.97.0 |
| pip | streampipes | < 0.97.0 | 0.97.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Streampipes | before 0.97.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/j14w6wghlwwrgfgc6hoz9f94fwxtlgzh
- http://www.openwall.com/lists/oss-security/2025/03/03/1
- https://github.com/advisories/GHSA-vm7w-2724-5m23
- https://nvd.nist.gov/vuln/detail/CVE-2024-24778
- https://github.com/pypa/advisory-database/tree/main/vulns/streampipes/PYSEC-2025-66.yaml