critical9.1
CVE-2024-25141
When ssl was enabled for Mongo Hook, default settings included "allow_insecure" which caused that certificates were not validated.
Impact
When ssl was enabled for Mongo Hook, default settings included "allow_insecure" which caused that certificates were not validated. This was unexpected and undocumented. Users are recommended to upgrade to version 4.0.0, which fixes this issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | apache-airflow-providers-mongo | < 4.0.0 | 4.0.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Apache-Airflow-Providers-Mongo | from 1.0.0 before 4.0.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-x5pm-h33q-cjrw
- https://nvd.nist.gov/vuln/detail/CVE-2024-25141
- https://github.com/apache/airflow/pull/37214
- https://lists.apache.org/thread/sqgbfqngjmn45ommmrgj7hvs7fgspsgm
- http://www.openwall.com/lists/oss-security/2024/02/20/5
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-mongo/PYSEC-2026-278.yaml
- https://pypi.org/project/apache-airflow-providers-mongo