high8.1
CVE-2024-25710
Apache Commons Compress: Denial of service caused by an infinite loop for a corrupted DUMP file
Impact
Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Commons Compress. This issue affects Apache Commons Compress: from 1.3 through 1.25.0. Users are recommended to upgrade to version 1.26.0 which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.commons:commons-compress | >= 1.3, < 1.26.0 | 1.26.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Commons Compress | from 1.3 before 1.26.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2024/02/19/1
- https://lists.apache.org/thread/cz8qkcwphy4cx8gltn932ln51cbtq6kf
- https://security.netapp.com/advisory/ntap-20240307-0010/
- http://seclists.org/fulldisclosure/2024/Aug/37
- https://github.com/advisories/GHSA-4g9r-vxhx-9pgx
- https://nvd.nist.gov/vuln/detail/CVE-2024-25710
- https://security.netapp.com/advisory/ntap-20240307-0010