NetSight
high6.5

CVE-2024-25723

ZenML Server Remote Privilege Escalation Vulnerability

Impact

ZenML Server in the ZenML package before 0.46.7 for Python allows remote privilege escalation because the `/api/v1/users/{user_name_or_id}/activate` REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.

Affected packages

EcosystemPackageAffectedFixed in
pipzenml< 0.42.20.42.2

Affected products

VendorProductAffected versions
ZenmlZenml
before 0.42.2
from 0.44.0 before 0.44.4
from 0.45.0 before 0.46.7
Version 0.43.0

Weakness classification

References