NetSight
medium4.6

CVE-2024-26140

Cross-site Scripting Vulnerability in Statement Browser

Impact

### Impact A maliciously crafted xAPI statement could be used to perform script or other tag injection in the LRS Statement Browser. ### Patches The problem is patched in version 1.2.17 of the LRS library and [version 0.7.5 of SQL LRS](https://github.com/yetanalytics/lrsql/releases/tag/v0.7.5). ### Workarounds No workarounds exist, we recommend upgrading to version 1.2.17 of the library or version 0.7.5 of SQL LRS immediately. ### References * [LRS Tag](https://github.com/yetanalytics/lrs/releases/tag/v1.2.17) * [LRS lib on Clojars](https://clojars.org/com.yetanalytics/lrs/versions/1.2.17) * [SQL LRS 0.7.5 Release](https://github.com/yetanalytics/lrsql/releases/tag/v0.7.5)

Affected packages

EcosystemPackageAffectedFixed in
mavencom.yetanalytics:lrs< 1.2.171.2.17

Affected products

VendorProductAffected versions
YetanalyticsLrs
before 1.2.17
YetanalyticsSql Lrs
before 0.7.5

Weakness classification

References