NetSight
critical9.8

CVE-2024-26579

Apache Inlong Deserialization of Untrusted Data vulnerability

Impact

Deserialization of Untrusted Data vulnerability in Apache InLong. This issue affects Apache InLong: from 1.7.0 through 1.11.0. The attackers can bypass using malicious parameters. Users are advised to upgrade to Apache InLong's 1.12.0 or cherry-pick [1], [2] to solve it. [1] https://github.com/apache/inlong/pull/9694 [2]  https://github.com/apache/inlong/pull/9707

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.inlong:manager-pojo>= 1.7.0, < 1.12.01.12.0

Affected products

VendorProductAffected versions
ApacheInlong
from 1.7.0 before 1.12.0

Weakness classification

References