critical9.1
CVE-2024-26580
Apache InLong: Logged-in user could exploit an arbitrary file read vulnerability
Impact
Deserialization of Untrusted Data vulnerability in Apache InLong.This issue affects Apache InLong: from 1.8.0 through 1.10.0, the attackers can use the specific payload to read from an arbitrary file. Users are advised to upgrade to Apache InLong's 1.11.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/9673
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.inlong:manager-common | >= 1.8.0, < 1.11.0 | 1.11.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Inlong | from 1.4.0 before 1.11.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2024/03/06/1
- https://lists.apache.org/thread/xvomf66l58x4dmoyzojflvx52gkzcdmk
- https://github.com/advisories/GHSA-p2gx-4434-pf6g
- https://nvd.nist.gov/vuln/detail/CVE-2024-26580
- https://github.com/apache/inlong/pull/9673
- https://github.com/apache/inlong/commit/1b63af3e1f208602f60b5ce19af7413443c3027c