medium6.3
CVE-2024-27136
Cross site scripting in Apache JSPWiki
Impact
XSS in Upload page in Apache JSPWiki 2.12.1 and priors allows the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.2 or later.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.jspwiki:jspwiki-main | < 2.12.2 | 2.12.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Jspwiki | before 2.12.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2024-27136
- https://lists.apache.org/thread/gfms8gbncqqkj52p861b8fnsypwsl1d5
- http://www.openwall.com/lists/oss-security/2024/06/23/3
- https://github.com/advisories/GHSA-36gf-vpj2-j42w
- https://nvd.nist.gov/vuln/detail/CVE-2024-27136