high5.3
CVE-2024-27181
Apache Linkis vulnerable to privilege escalation
Impact
In Apache Linkis <= 1.5.0, Privilege Escalation in Basic management services where the attacking user is a trusted account allows access to Linkis's Token information. Users are advised to upgrade to version 1.6.0, which fixes this issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.linkis:linkis | < 1.6.0 | 1.6.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Linkis | before 1.6.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/hosd73l7hxb3rpt5rb0yg0ld11zph4c6
- http://www.openwall.com/lists/oss-security/2024/08/02/3
- https://github.com/advisories/GHSA-v352-rg37-5q5m
- https://nvd.nist.gov/vuln/detail/CVE-2024-27181
- https://www.openwall.com/lists/oss-security/2024/08/02/3