NetSight
high4.9

CVE-2024-27182

Apache Linkis arbitrary file deletion vulnerability

Impact

In Apache Linkis <= 1.5.0, Arbitrary file deletion in Basic management services on a user with an administrator account could delete any file accessible by the Linkis system user. Users are recommended to upgrade to version 1.6.0, which fixes this issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.linkis:linkis< 1.6.01.6.0

Affected products

VendorProductAffected versions
ApacheLinkis
from 1.3.2 before 1.6.0

Weakness classification

References