NetSight
medium5.1

CVE-2024-27906

Apache Airflow: DAG Code and Import Error Permissions Ignored

Impact

Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI. Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow<= 2.8.12.8.2

Affected products

VendorProductAffected versions
ApacheAirflow
before 2.8.2

Weakness classification

References