medium4.3
CVE-2024-28148
Apache Superset Incorrect Authorization vulnerability
Impact
An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a targeted REST API request. This issue affects Apache Superset before 3.1.2. Users are recommended to upgrade to version 3.1.2 or above, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | apache-superset | < 3.1.2 | 3.1.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Superset | before 4.0.0 |