NetSight
high8.1

CVE-2024-28746

Apache Airflow: Ignored Airflow Permission

Impact

Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access.  Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow>= 2.8.0, < 2.8.3rc12.8.3rc1

Affected products

VendorProductAffected versions
ApacheAirflow
from 2.8.0 before 2.8.3

Weakness classification

References