high7.3
CVE-2024-29131
Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator()
Impact
This Out-of-bounds Write vulnerability in Apache Commons Configuration affects Apache Commons Configuration: from 2.0 before 2.10.1. User can see this as a 'StackOverflowError' when adding a property in 'AbstractListDelimiterHandler.flattenIterator()'. Users are recommended to upgrade to version 2.10.1, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.commons:commons-configuration2 | >= 2.0, < 2.10.1 | 2.10.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Commons Configuration | from 2.0 before 2.10.1 |
| Fedoraproject | Fedora | Versions 39, 40 |
| Netapp | Ontap Tools | Version 10 |
| Netapp | Snapcenter | All versions |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2024/03/20/4
- https://lists.apache.org/thread/03nzzzjn4oknyw5y0871tw7ltj0t3r37
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/SNKDKEEKZNL5FGCTZKJ6CFXFVWFL5FJ7/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YD4AFTIIQW662LUAQRMWS6BBKYSZG3YS/
- https://security.netapp.com/advisory/ntap-20241213-0001/
- https://github.com/advisories/GHSA-xjp4-hw94-mvp5
- https://nvd.nist.gov/vuln/detail/CVE-2024-29131
- https://github.com/apache/commons-configuration/commit/56b5c4dcdffbde27870df5a3105d6a5f9b22f554
- https://issues.apache.org/jira/browse/CONFIGURATION-840
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YD4AFTIIQW662LUAQRMWS6BBKYSZG3YS
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/SNKDKEEKZNL5FGCTZKJ6CFXFVWFL5FJ7
- https://security.netapp.com/advisory/ntap-20241213-0001