NetSight
medium6.5

CVE-2024-29133

Apache Commons Configuration: StackOverflowError calling ListDelimiterHandler.flatten(Object, int) with a cyclical object tree

Impact

This Out-of-bounds Write vulnerability in Apache Commons Configuration affects Apache Commons Configuration: from 2.0 before 2.10.1. User can see this as a 'StackOverflowError' calling 'ListDelimiterHandler.flatten(Object, int)' with a cyclical object tree. Users are recommended to upgrade to version 2.10.1, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.commons:commons-configuration2>= 2.0, < 2.10.12.10.1

Affected products

VendorProductAffected versions
ApacheCommons Configuration
from 2.0 before 2.10.1
FedoraprojectFedora
Versions 39, 40

Weakness classification

References