NetSight
medium5.4

CVE-2024-29217

Apache Answer: XSS vulnerability when changing personal website

Impact

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'/`XSS`) vulnerability in Apache Answer.This issue affects Apache Answer: before 1.3.0. XSS attack when user changes personal website. A logged-in user, when modifying their personal website, can input malicious code in the website to create such an attack. Users are recommended to upgrade to version [1.3.0], which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
gogithub.com/apache/incubator-answer< 1.3.01.3.0

Affected products

VendorProductAffected versions
ApacheAnswer
before 1.3.0

Weakness classification

References