NetSight
low2.7

CVE-2024-29733

Improper Certificate Validation vulnerability in Apache Airflow FTP Provider

Impact

Improper Certificate Validation vulnerability in Apache Airflow FTP Provider. The FTP hook lacks complete certificate validation in FTP_TLS connections, which can potentially be leveraged. Implementing proper certificate validation by passing context=ssl.create_default_context() during FTP_TLS instantiation is used as mitigation to validate the certificates properly. This issue affects Apache Airflow FTP Provider: before 3.7.0. Users are recommended to upgrade to version 3.7.0, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow-providers-ftp< 3.7.03.7.0

Affected products

VendorProductAffected versions
ApacheApache-Airflow-Providers-Ftp
before 3.7.0

Weakness classification

References