NetSight
medium

CVE-2024-31861

Code injection in Apache Zeppelin Shell

Impact

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Zeppelin. The attackers can use Shell interpreter as a code generation gateway, and execute the generated code as a normal way. This issue affects Apache Zeppelin: from 0.10.1 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which doesn't have Shell interpreter by default.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.zeppelin:zeppelin-shell>= 0.10.1, < 0.11.10.11.1

Weakness classification

References