medium5.3
CVE-2024-31862
Apache Zeppelin: Denial of service with invalid notebook name
Impact
Improper Input Validation vulnerability in Apache Zeppelin when creating a new note from Zeppelin's UI. This issue affects Apache Zeppelin from 0.10.1 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.zeppelin:zeppelin-server | >= 0.10.1, < 0.11.0 | 0.11.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Zeppelin | from 0.10.1 before 0.11.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2024/04/09/5
- https://github.com/apache/zeppelin/pull/4632
- https://lists.apache.org/thread/73xdjx43yg4yz8bd4p3o8vzyybkysmn0
- https://github.com/advisories/GHSA-6623-c6mr-6737
- https://nvd.nist.gov/vuln/detail/CVE-2024-31862
- https://github.com/apache/zeppelin/commit/f025a697c1d1d0264064d5adf6cb0b20d85041b6