medium6.5
CVE-2024-31863
Apache Zeppelin: Replacing other users notebook, bypassing any permissions
Impact
Authentication Bypass by Spoofing vulnerability by replacing to exsiting notes in Apache Zeppelin. This issue affects Apache Zeppelin: from 0.10.1 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.zeppelin:zeppelin-server | >= 0.10.1, < 0.11.0 | 0.11.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Zeppelin | Version 0.10.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2024/04/09/6
- https://lists.apache.org/thread/3od2gfpwllmtc9c5ggw04ohn8s7w3ct9
- https://github.com/advisories/GHSA-m65c-wmw9-vmpp
- https://nvd.nist.gov/vuln/detail/CVE-2024-31863
- https://github.com/apache/zeppelin/commit/f025a697c1d1d0264064d5adf6cb0b20d85041b6