medium5.4
CVE-2024-31865
Apache Zeppelin: Cron arbitrary user impersonation with improper privileges
Impact
Improper Input Validation vulnerability in Apache Zeppelin. The attackers can call updating cron API with invalid or improper privileges so that the notebook can run with the privileges. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.zeppelin:zeppelin-server | >= 0.8.2, < 0.11.1 | 0.11.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Zeppelin | from 0.8.2 before 0.11.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2024/04/09/9
- https://github.com/apache/zeppelin/pull/4631
- https://lists.apache.org/thread/slm1sf0slwc11f4m4r0nd6ot2rf7w81l
- https://github.com/advisories/GHSA-g44m-x5h7-fr5q
- https://nvd.nist.gov/vuln/detail/CVE-2024-31865
- https://github.com/apache/zeppelin/commit/49e2740a1d83d58d2401ccf175fc91ffebfb0892