medium5.9
CVE-2024-31867
Apache Zeppelin: LDAP search filter query Injection Vulnerability
Impact
Improper Input Validation vulnerability in Apache Zeppelin. The attackers can execute malicious queries by setting improper configuration properties to LDAP search filter. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.zeppelin:zeppelin-server | >= 0.8.2, < 0.11.1 | 0.11.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Zeppelin | from 0.8.2 before 0.11.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2024/04/09/12
- https://github.com/apache/zeppelin/pull/4714
- https://lists.apache.org/thread/s4scw8bxdhrjs0kg0lhb68xqd8y9lrtf
- https://github.com/advisories/GHSA-qmr3-52xf-wmhx
- https://nvd.nist.gov/vuln/detail/CVE-2024-31867
- https://github.com/apache/zeppelin/commit/65d0bcc1ee8ec3ec372d0a71ab513cd20e6522a0