medium6.1
CVE-2024-31868
Apache Zeppelin vulnerable to cross-site scripting in the helium module
Impact
Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. Attackers can modify `helium.json` and perform cross-site scripting attacks on normal users. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.zeppelin:zeppelin-interpreter | >= 0.8.2, < 0.11.1 | 0.11.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Zeppelin | from 0.8.2 before 0.11.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/apache/zeppelin/pull/4728
- https://lists.apache.org/thread/55mqs673plsxmgnq7fdf2flftpllyf11
- http://www.openwall.com/lists/oss-security/2024/04/09/11
- https://github.com/advisories/GHSA-rrvf-5w4r-3x7v
- https://nvd.nist.gov/vuln/detail/CVE-2024-31868
- https://github.com/apache/zeppelin/commit/83685795e0ec8d3059fd7a3dbcae5c0532b63b79