high8.1
CVE-2024-32004
Git is a revision control system.
Impact
Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, an attacker can prepare a local repository in such a way that, when cloned, will execute arbitrary code during the operation. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid cloning repositories from untrusted sources.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Git-Scm | Git | before 2.39.4 from 2.40.0 before 2.40.2 from 2.42.0 before 2.42.2 from 2.43.0 before 2.43.4 Versions 2.41.0, 2.44.0 |
| Fedoraproject | Fedora | Version 40 |
| Debian | Debian Linux | Versions 10.0, 11.0 |
Weakness classification
References
- NVD record
- CVE.org record
- http://www.openwall.com/lists/oss-security/2024/05/14/2
- https://git-scm.com/docs/git-clone
- https://github.com/git/git/commit/f4aa8c8bb11dae6e769cd930565173808cbb69c8
- https://github.com/git/git/security/advisories/GHSA-xfc6-vwr8-r389
- https://lists.debian.org/debian-lts-announce/2024/06/msg00018.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/S4CK4IYTXEOBZTEM5K3T6LWOIZ3S44AR/
- http://www.openwall.com/lists/oss-security/2024/05/14/2
- https://git-scm.com/docs/git-clone
- https://github.com/git/git/commit/f4aa8c8bb11dae6e769cd930565173808cbb69c8
- https://github.com/git/git/security/advisories/GHSA-xfc6-vwr8-r389
- https://lists.debian.org/debian-lts-announce/2024/06/msg00018.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/S4CK4IYTXEOBZTEM5K3T6LWOIZ3S44AR/