NetSight
high7.3

CVE-2024-32474

Sentry vulnerable to leaking superuser cleartext password in logs

Impact

### Impact When authenticating as a superuser to a self-hosted Sentry instance with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. ### Patches - Self-hosted users on affected versions should upgrade to 24.4.1 or later. - Sentry SaaS users do not need to take any action. This vulnerability is not applicable to SaaS. ### Workarounds Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or higher. For details on configuring self-hosted Sentry's logging level see our documentation at: https://develop.sentry.dev/config/#logging ### References - Bug introduced in https://github.com/getsentry/sentry/pull/66393 - Security fix in https://github.com/getsentry/sentry/pull/69148

Affected packages

EcosystemPackageAffectedFixed in
pipsentry>= 24.3.0, < 24.4.124.4.1

Affected products

VendorProductAffected versions
SentrySentry
from 24.3.0 before 24.4.1

Weakness classification

References