medium5.4
CVE-2024-34356
TYPO3 vulnerable to Cross-Site Scripting in the Form Manager Module
Impact
### Problem The form manager backend module is vulnerable to cross-site scripting. Exploiting this vulnerability requires a valid backend user account with access to the form module. ### Solution Update to TYPO3 versions 9.5.48 ELTS, 10.4.45 ELTS, 11.5.37 LTS, 12.4.15 LTS, 13.1.1 that fix the problem described. ### Credits Thanks to TYPO3 core & security team member Benjamin Franzke who reported and fixed the issue. ### References * [TYPO3-CORE-SA-2024-008](https://typo3.org/security/advisory/typo3-core-sa-2024-008)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | typo3/cms-core | >= 9.0.0, <= 9.5.47 | 9.5.48 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Typo3 | Typo3 | from 9.0.0 before 9.5.48 from 10.0.0 before 10.4.45 from 11.0.0 before 11.5.37 from 12.0.0 before 12.4.15 from 13.0.0 before 13.1.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/TYPO3/typo3/commit/2832e2f51f929aeddb5de7d667538a33ceda8156
- https://github.com/TYPO3/typo3/commit/d0393a879a32fb4e3569acad6bdb5cda776be1e5
- https://github.com/TYPO3/typo3/commit/e95a1224719efafb9cab2d85964f240fd0356e64
- https://github.com/TYPO3/typo3/security/advisories/GHSA-v6mw-h7w6-59w3
- https://typo3.org/security/advisory/typo3-core-sa-2024-008
- https://github.com/advisories/GHSA-v6mw-h7w6-59w3
- https://nvd.nist.gov/vuln/detail/CVE-2024-34356