low3.5
CVE-2024-34713
sshproxy vulnerable to SSH option injection
Impact
### Impact Any user authorized to connect to a ssh server using `sshproxy` can inject options to the `ssh` command executed by `sshproxy`. All versions of `sshproxy` are impacted. ### Patches The problem is patched starting on version 1.6.3 ### Workarounds The only workaround is to use the `force_command` option in `sshproxy.yaml`, but it's rarely relevant. ### References
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/cea-hpc/sshproxy | <= 1.6.2 | 1.6.3 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/cea-hpc/sshproxy/commit/f7eabd05d5f0f951e160293692327cad9a7d9580
- https://github.com/cea-hpc/sshproxy/security/advisories/GHSA-jmqp-37m5-49wh
- https://github.com/advisories/GHSA-jmqp-37m5-49wh
- https://nvd.nist.gov/vuln/detail/CVE-2024-34713
- https://github.com/cea-hpc/sshproxy/commit/3b8bccc874dc4ca2c80c956cad65722abb46f0b9