NetSight
high8.2

CVE-2024-36110

ansibleguy-webui Cross-site Scripting vulnerability

Impact

### Impact Multiple forms in version <0.0.21 allowed injection of HTML elements. These are returned to the user after executing job actions and thus evaluated by the browser. ### Patches We recommend to upgrade to version >= [0.0.21](https://github.com/ansibleguy/webui/releases/tag/0.0.21) ### References * [Report](https://github.com/ansibleguy/webui/files/15358522/Report.pdf) * [GitHub Issue 44](https://github.com/ansibleguy/webui/issues/44)

Affected packages

EcosystemPackageAffectedFixed in
pipansibleguy-webui< 0.0.210.0.21

Affected products

ProductAffected versions
Versions
before 0.0.21

Versions were read from the advisory text. No structured product data has been published for this record yet.

Weakness classification

References