NetSight
critical9.8

CVE-2024-36268

Apache Inlong Code Injection vulnerability

Impact

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache InLong. This issue affects Apache InLong: from 1.10.0 through 1.12.0, which could lead to Remote Code Execution. Users are advised to upgrade to Apache InLong's 1.13.0 or cherry-pick [1] to solve it. [1]  https://github.com/apache/inlong/pull/10251

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.inlong:tubemq-core>= 1.10.0, < 1.13.01.13.0

Affected products

VendorProductAffected versions
ApacheInlong
from 1.10.0 before 1.13.0

Weakness classification

References