critical9.8
CVE-2024-36522
Apache Wicket: Remote code execution via XSLT injection
Impact
The default configuration of XSLTResourceStream.java is vulnerable to remote code execution via XSLT injection when processing input from an untrusted source without validation. Users are recommended to upgrade to versions 10.1.0, 9.18.0 or 8.16.0, which fix this issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.wicket:wicket-util | >= 10.0.0-M1, < 10.1.0 | 10.1.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Wicket | from 8.0.0 before 8.16.0 from 9.0.0 before 9.18.0 Version 10.0.0 |