medium5.4
CVE-2024-37389
Apache NiFi vulnerable to Cross-site Scripting
Impact
Apache NiFi 1.10.0 through 1.26.0 and 2.0.0-M1 through 2.0.0-M3 support a description field in the Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.27.0 or 2.0.0-M4 is the recommended mitigation.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.nifi:nifi-web-ui | >= 1.10.0, < 1.27.0 | 1.27.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Nifi | from 1.10.0 before 1.27.0 Version 2.0.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/yso9fr0wtff53nk046h1o83hdyb1lrxh
- http://www.openwall.com/lists/oss-security/2024/07/08/1
- https://github.com/advisories/GHSA-h658-qqv9-qwv8
- https://nvd.nist.gov/vuln/detail/CVE-2024-37389
- https://github.com/apache/nifi/pull/8938
- https://github.com/apache/nifi/commit/1ea0bc1f7fa90ecff0ceb8b0c91a9aebeb05893b
- https://issues.apache.org/jira/browse/NIFI-13374