NetSight
high6.5

CVE-2024-38503

Apache Syncope Improper Input Validation vulnerability

Impact

When editing a user, group or any object in the Syncope Console, HTML tags could be added to any text field and could lead to potential exploits. The same vulnerability was found in the Syncope Enduser, when editing "Personal Information" or "User Requests". Users are recommended to upgrade to version 3.0.8, which fixes this issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui>= 2.1.0, < 3.0.83.0.8
mavenorg.apache.syncope.client.idrepo:syncope-client-idrepo-console>= 2.1.0, < 3.0.83.0.8

Affected products

VendorProductAffected versions
ApacheSyncope
from 2.1.0 through 2.1.14
from 3.0.0 before 3.0.8

Weakness classification

References