high7.5
CVE-2024-39693
Next.js Denial of Service (DoS) condition
Impact
### Impact A Denial of Service (DoS) condition was identified in Next.js. Exploitation of the bug can trigger a crash, affecting the availability of the server. **This vulnerability can affect all Next.js deployments on the affected versions.** ### Patches This vulnerability was resolved in Next.js 13.5 and later. We recommend that users upgrade to a safe version. ### Workarounds There are no official workarounds for this vulnerability. #### Credit * Thai Vu of [flyseccorp.com](http://flyseccorp.com/) * Aonan Guan (@0dd), Senior Cloud Security Engineer
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | next | >= 13.3.1, < 13.5.0 | 13.5.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Vercel | Next.Js | from 13.3.1 before 13.5.0 |