NetSight
medium5.4

CVE-2024-39863

Apache Airflow Potential Cross-site Scripting Vulnerability

Impact

Apache Airflow versions before 2.9.3 have a vulnerability that allows an authenticated attacker to inject a malicious link when installing a provider. Users are recommended to upgrade to version 2.9.3, which fixes this issue.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow< 2.9.32.9.3

Affected products

VendorProductAffected versions
ApacheAirflow
before 2.9.3

Weakness classification

References