NetSight
high8.8

CVE-2024-39877

Apache Airflow has DAG Author Code Execution possibility in airflow-scheduler

Impact

Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow>= 2.4.0, < 2.9.32.9.3

Affected products

VendorProductAffected versions
ApacheAirflow
from 2.4.0 before 2.9.3

Weakness classification

References